PureWeb 4.3 Upgrade Notes

Applications made using the 4.2.x version of the PureWeb SDK may require modifications to upgrade them to the current 4.3 release. These Upgrade Notes will help you identify the specific changes.

Changes to the iOS APIs

The following method from the PWAssertion class is now deprecated:

+ (void)runModal:(UIAlertView *)view

This method was used to display alert messages as modal dialogs, functionality which was not provided natively by the Objective-C UIAlertView class, However, since UIAlertView has been deprecated as of iOS 8.0, this workaround is no longer required.

You should now use the native Objective-C UIAlertController class to display alert messages as modal dialogs.

Changes to the HTML5 APIs

The following methods from the stringUtil class were deemed unnecessary and have been marked as deprecated:

  • encodeUTF8
  • decodeUTF8

Changes to the PureWeb server

The PureWeb server now uses Spring Framework 4.3 and Spring Security 4.2 (in previous releases, it was using Spring Framework 3.2 and Spring Security 3.2).

If your application did not take advantage of Spring functionality beyond PureWeb, you do not need to complete any special steps to migrate to PureWeb 4.3.

If, however, your application did take advantage of Spring functionality beyond PureWeb, we encourage you to review the migration guide created by Spring to determine if any additional steps are needed.

Developer Tool Changes

Some of the tools, or versions of tools, required for development have changed, as summarized below. For a complete list of supported platforms and tools, refer to the Requirements.

  • The minimum supported version of Android is now 5.x, and the minimum API level is 21.

  • Mac OS 10.11 or 10.12, Xcode 8 and Cocoapods 1.1 are now required for iOS development. If you are developing in Swift, you need Swift 3.x. The minimum target on user devices is iOS 9.
  • The HTLM5 client SDK no longer supports Firefox ESR. Only the latest version of Firefox is now supported.
  • If developing on Ubuntu, you now need Ubuntu 14.04 LTS.